Processes Instances Error with Deadlocks on GCP Environment
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Processes Instances Error with Deadlocks on GCP Environment

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Article ID: 218219

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

An example process that creates a budget plan errors with following error in the BG log:

<Server>/niku/nu#action:bpm.processInstanceErrorReturn&showErrors=true&message_type&status&process_instance_id=5074129&object_type=admin&ui.page.space=bpm.processDefinitions&ui.page.template=union.adminPage&bpm.returnModuleAction=bpm.processInstancesReturn&uitk.session.uuid=xxxxx

[XOG]Xog operation failed. Error updating data in FIN_FINANCIALS table com.niku.union.service.ServiceException: Error updating data in FIN_FINANCIALS table
Caused by: com.niku.union.persistence.PersistenceDeadlockException: 
SQL error code: 0
Error message: ERROR: deadlock detected
  Detail: Process 30846 waits for ShareLock on transaction 223092032; blocked by process 31311.
Process 31311 waits for ShareLock on transaction 223092025; blocked by process 30846.
  Hint: See server log for query details.
  Where: while locking tuple (14,16) in relation "inv_investments"

 

Environment

Release : 15.9.2

Component : CA PPM SAAS BUSINESS PROCESS MANAGEMENT

Cause

The issue could be attributed to a temporary disruption in the database connection, as the issue is not able to be reproduced at will.

Resolution

In one case, the following steps were implemented just in case the issue were to happen again:


1. In the CSA, enable Process Engine Persistence Logging to INFO level, to have further logging in the BG logs if an issue does happen again.

2. If a process is involved, modify the process to provide additional logging in the steps so that if an error occurs in a step,
it provides additional information on where and why it failed. The information will then be provided when the 'Show Details' button of the failed instance is clicked.

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