Error authenticating proxy
search cancel

Error authenticating proxy

book

Article ID: 218206

calendar_today

Updated On:

Products

Information Centric Analytics

Issue/Introduction

When running the Information Centric Analytics' (ICA) RiskFabric Processing job, RiskFabric Intraday Processing job, a RiskFabric_IW_DataSourceQueryID_<n> job, or the Bay Dynamics AD Connector job, a job step fails and returns an error similar to the following:

Unable to start execution of step n (reason: Error authenticating proxy <domain\account>, system error: The user name or password is incorrect.).  The step failed.
Unable to start execution of step n (reason: Error authenticating proxy <domain\account>, system error: The referenced account is currently locked out and may not be logged on to.).  The step failed.

Environment

Release : 6.x

Component : RiskFabric Processing, RiskFabric Intraday Processing, Bay Dynamics AD Connector Job

Cause

The credentials provided for one of the proxy accounts used by RiskFabric are invalid. These proxies are:

  • Operating System (CmdExec) > Bay Dynamics AD Connector Proxy
  • Operating System (CmdExec) > RiskFabric Nightly Processing
  • Analysis Services Command > RiskFabric Proxy

This error often follows a change or update to the ICA service account password in Active Directory.

Resolution

To correct the credential used by the proxy named in the error above, follow this procedure:

  1. Open SQL Server Management Studio (SSMS)
  2. Connect to the Database Engine hosting the RiskFabric database
  3. In Object Explorer, navigate to SQL Server Agent > Proxies
  4. Navigate to the subfolder containing the proxy to be updated (see the paths provided in the Cause section of this article)
  5. Right-click the proxy to be updated and select Properties
    The Proxy Account Properties window opens
  6. In the Proxy Account Properties window, note the Credential name specified for the proxy
  7. Click the Cancel button to close the Proxy Account Properties window
  8. In Object Explorer, navigate to Security > Credentials
  9. Right-click the credential identified in step 6 and select Properties
  10. In the Credential Properties window, enter the password for the Identity specified
  11. Click the OK button

To update all instances of the service account password following a service account password reset or change, follow the procedures documented in Broadcom KB article 226575. That article is available at the following URL:

https://knowledge.broadcom.com/external/article?articleNumber=226575