Admin Console and Operator Console not accessible and wasp not responding
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Admin Console and Operator Console not accessible and wasp not responding

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Article ID: 218162

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) Unified Infrastructure Management for Mainframe CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

We are running UIM 20.3.0. Current wasp probe version is 20.31. We are not able to access the Admin Console.

Earlier wasp was running fine, even then we were not able to access the admin console, so we installed adminconsoleapp package on the Primary hub robot. After this, the wasp probe didn't respond. Also post-upgrade to 20.3.3, Admin console and Operator console are still not working. 

wasp.log shows an error:

ERROR [main, com.nimsoft.nimbus.probe.service.wasp.Probe] main() org.apache.catalina.LifecycleException: A child container failed during start

Environment

  • Release: 20.3, also this may apply to 20.4
  • Component : UIM OPERATOR CONSOLE - WASP & CORE
  • UIM 20.3.0, 20.3.3
  • wasp

Cause

  • Initial install of OC done on Primary hub robot
  • No write permissions on the Nimsoft folder

Resolution

In some cases where this issue has occurred, we have seen leftover webapp artifacts exist in the webapps section of wasp.cfg and have to be removed, and wasp then needs to be cold started. As it happened in this case, the 'artifacts' may also be due to the customer accidentally running the OC installer (on the Primary as recommended, but choosing the Primary instead of the designated UMP/OC robot as the target for the OC install.)

One of the main symptoms of this upgrade issue you may notice is that in the wasp log at loglevel 5 you will see an error:
ERROR [main, com.nimsoft.nimbus.probe.service.wasp.Probe] main() Fatal error!
ERROR [main, com.nimsoft.nimbus.probe.service.wasp.Probe] main() org.apache.catalina.LifecycleException: A child container failed during start

We ran across another scenario where post-upgrade the wasp will not start on the Primary nor the OC machine. This forced us to have to manually extract the webapp .war files on the server. In the process of doing so, the customer discovered that the webapp .war files could not be extracted due to a permissions issue even though the user was in the Windows Administrators group. This occurred on a Windows 2016 server.

Warning:

User Account Control
UAC treats members of the Administrators group as Standard users. With UAC enabled, members of the local Administrators group run with the same access token as Standard users.

  • Therefore, on the Primary Hub and the OC machine, All permissions MUST be granted to the Nimsoft folder as the user may not be able to write to the required folders, e.g., wasp->webapps so this is why the required webapp sections were not populated in the wasp.cfg

  • While granting UAC write permissions, we need to consider the whole machine instead of just the Nimsoft folder, because the installer writes some log files in other locations as well. For example, C:\tmp on Windows.

In 20.3.3, the minimum-required webapp section names (devoid of artifacts) should have included:

1. ROOT
2. uimesdplatelemetry
3. mps
4. uimhome
5. adminconsoleapp

Other sections:
The list below will not depend upon the installer. Those sections will be created when the user drags and drops other packages using IM/AC.

1. mcs-ws
2. ROOT
3. slm
4. uimesdplatelemetry
5. mps
6. mcs-ui-app
7. uimhome
8. uimapi
9. adminconsoleapp

Once the folder permissions were granted, and the webapps .war files were successfully extracted, the robot was restarted and wasp started up as well.

1. Prior to the upgrade, make sure you are not installing the OC on the Primary but if you do so accidentally, make sure you remove any unnecessary sections from the webapps section in the wasp.cfg, e.g., <cabijs>, <dashboard>, <dap>, etc..

2. Check the Nimsoft folder Properties->Security to ensure that the administrative user running the installation has full control/permissions on the Nimsoft folder BEFORE you start the install/upgrade process.

Additional Information

In the wasp.cfg, if the expected webapp sections are not displayed, you may have to manually extract the.war files.

To create the wasp webapp folders manually from the .war files:

1. Deactivate wasp

2. For the Primary hub wasp, create the folders manually named:

  • uimesdplatelemetry
  • mps
  • uimhome
  • adminconsoleapp

3. If the issue is with the wasp for the OC Robot machine, create the folders manually named:

  •     alarmviewer-api
  •     nisapi
  •     operatorconsole_portlet
  •     samlsso
  •     cabi
  •     ROOT
  •     slm
  •     dashboard
  •     mcs-ui-app
  •     reportscheduler
  •     accountadmin
  •     policy_management_ws

4. Change the extension of the webapp files from .war to .zip
5. Rt-click and select extract option from 7-Zip
6. Rename .zip back to .war