https 400 response when bulk editing incidents in 15.8
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https 400 response when bulk editing incidents in 15.8

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Article ID: 218091

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Updated On:

Products

Data Loss Prevention

Issue/Introduction

Setting the status on multiple incidents by going through Scan History>Scan Details> Click on incident Links> Click Show all> Then under Incident actions selection an action. The following HTTP status 400 is received. 

 

Environment

Release : 15.8

Component :tomcat

Cause

invalid characters passing to webserver

Resolution

Edit the server.xml in:

Linux: /opt/Symantec/DataLossPrevention/EnforceServer/15.8.00000/Protect/tomcat/conf/

Windows: %Program Files%\Symantec\DataLossPrevetion\EnforceServer\<version>\Protect\tomcat\conf

add the relaxedQueryChars='^{}[]|"' to the connector SSLEnabled

Should look like below configuration: 

<Connector SSLEnabled="true" URIEncoding="UTF-8" acceptCount="100" disableUploadTimeout="true" enableLookups="false" maxThreads="150" port="443" scheme="https" secure="true" relaxedQueryChars='^{}[]|"'>