CA PAM A2A client can't start after upgrade and reboot
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CA PAM A2A client can't start after upgrade and reboot

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Article ID: 218028

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

A2A client upgrade an uninstallation sometimes ends up with a message that several folders must be removed manually.

During upgrade it may happen that once it is done, after a reboot the A2A client fails to start. 

This is likely caused by missing files in the A2A folder and the only known remediation is to reinstall the A2A client in the affected machine.

Environment

CA PRIVILEGED ACCESS MANAGEMENT several versions

Cause

A2A uninstall and likely reinstallation as well must be performed with the A2A client service stopped, to prevent from files not being deleted because they are in use.

If this situation happens, the corresponding file will be marked for deletion at next reboot. It may happen that some of the files marked for deletion have actually not been replaced in the installation folders while running the installer, so next reboot will delete them and it will cause this condition.

Resolution

The A2A client services need to be stopped before upgrade or uninstall operations can take place