CWP steps to remediate issues caused due to connection deletion
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CWP steps to remediate issues caused due to connection deletion

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Article ID: 218011

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Updated On:

Products

Cloud Workload Protection

Issue/Introduction

CWP connections are deleted, sync does not happen.

Environment

Cloud Workload Protection (CWP) Windows and Linux Client

Cause

Cloud Workload Protection for compute system initiated jobs deletes instance connections due to issues with Redis.

Resolution

Steps to re-enroll the agent:

 

Windows

 

  1. Open the command prompt and navigate to the location where CWP agent is copied (or copy new agent if installed agent on system is older)
  2. Execute the command to configure the enrolment parameters from the CMD (see parameters details in the end of document, parameters highlighted in red are mandatory, others are optional)

installagent.bat -configure -customer-id <customer Id> -domain-id <domain Id> -customer-secret-key <secret-key>
-tags <tags> -proxy-user-name <proxy user name> -proxy-password <proxy password> -proxy-protocol <proxy protocol>

  1. In case of newer version of agent is copied, it will upgrade the existing CWP agent. It may require of rebooting the system so that latest agent build to take effect.

 

Linux

  1. Open terminal and navigate to the installer location where CWP agent is copied (or copy new agent if installed agent on system is older).
  2. Execute the command to configure the enrolment parameters from the terminal (see parameters details in the end of document, parameters highlighted in red are mandatory, others are optional)

installagent.sh --configure --customer-id <cusomerId> --domain-id <domainId> --customer-secret-key <secret-key>
--tags <tags> --proxy-user-name <proxy user name> --proxy-password <proxy password> --proxy-protocol <proxy protocol>

  1. In case of newer version of agent is copied, it will upgrade the existing CWP agent. It may require of rebooting the system so that latest agent build to take effect.

 

Azure VM Extensions

For Azure VM Extensions below are the steps to enrol the agent again with CWP,

  • If customer secret key is same as in past used to enrol the agent.
    1. Reboot the server

this will initiate the enable phase of extension and re-enroll the agent

  • In case if customer has regenerated the secret key value used during the enrolment of agent which needs to be re-enrolled
    1. Update the extension settings either from Azure Portal or using extension installer scripts
    2. Reboot the server

this will initiate the enable phase of extension and re-enroll the agent

 

Parameters:

  • Customer Id : Customer Id of CWP account and can be captured from download tab under settings page.
  • Domain Id : Domain Id of CWP and can be captured from download tab under settings page.
  • Customer Secret Key : Secret Key of the CWP account and can be captured from download tab under settings page.
  • Proxy User Name : Name of the proxy user in case agent is installed using proxy.
  • Proxy Protocol : Proxy protocol used in case agent is installed using proxy.
  • Proxy Password : Password of the proxy user in case agent is installed using proxy.
  • Tags : Custom tags to be added for the enrolled agent.