Mail Security for Microsoft Exchange remote install fails after file copy
search cancel

Mail Security for Microsoft Exchange remote install fails after file copy

book

Article ID: 218005

calendar_today

Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

Symantec Mail Security for Microsoft Exchange (SMSMSE) remote install fails after file copy. Event viewer on the remote server has the following error:

Event ID 7009

A timeout was reached (30000 milliseconds) while waiting for the VPRemote install Bootstrap Service to connect

Procmon (Microsoft's Process Monitor) on the remote server shows the VPRemote process ending with status -1073741515. Additionally, the procmon shows VPRemote failing to load ccLib.dll and libeay32.dll.

Cause

When SMSMSE performs a remote install, the files are copied over the network to the target machine. VPRemote is installed as a temporary service. This service then invokes the installation on the server. This process relies on ccLib.dll and libeay32.dll.

Resolution

We can send these files over with the install files. This will allow VPRemote to find the dlls with the install files and successfully start.

  1. On the console machine, go to C:\Windows\System32
  2. Find the following two files:
    • ccLib.dll
    • libeay32.dll.
  3. Copy these two files to C:\Program Files\Symantec\CMaF\<SMSMSE Version>\bin\Products\SMSMSE\<SMSMSE Version>\Remote Install Files
    1. Example path: C:\Program Files\Symantec\CMaF\7.9\bin\Products\SMSMSE\7.9\Remote Install Files
  4. On the target server, remove C:\Program Files\Symantec\SMSMSE751_Install.
  5. Perform the remote installation again.