UIM| CABI is not available when login as LDAP user and access reports from OC
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UIM| CABI is not available when login as LDAP user and access reports from OC

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Article ID: 217953

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

When login to OC and trying to access reports get "CABI is not available or accessible" however when logging in as Administrator reports work as expected.

Environment

Release : 20.3

Component : UIM OPERATOR CONSOLE - CABI REPORTS AND INTEGRATION

Probe: Cabi_external

Cause

Based on the Cabi_external logs

Jun 21 11:54:03:038 [attach_socket, cabi_external] ensure_js_user_exists callback failed: com.ca.cabi4uim.sso.exceptions.UserSynchronizationException: Error ensuring user juserl in organization UIM exists
Jun 21 11:54:03:038 [attach_socket, cabi_external] com.ca.cabi4uim.sso.exceptions.UserSynchronizationException: Error ensuring user juserl in organization UIM exists
Caused by: com.ca.cabi4uim.sso.exceptions.JasperUserUtilityException: Error creating user '<username>' in organization 'UIM', got unexpected response code '400' and body '{"message":"The value \"{1}\" for parameter \"ROLE_REPORT_DESIGNER\" is invalid."

Resolution

1- Login to cabi directly as superuser.

2- Select Manage then Roles

3- Role ROLE_REPORT_DESIGNER was missing from the External_cabi roles.

The "ROLE_REPORT_DESIGNER"  should have been created by default during the installation. 

4- Add the ROLE_REPORT_DESIGNER and assign the user to it.

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