Agent log generation utilizing high Disk Space and some logs are not arhiving
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Agent log generation utilizing high Disk Space and some logs are not arhiving

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Article ID: 217939

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Updated On:

Products

CA Workload Automation AE - System Agent (AutoSys) CA Workload Automation DE - System Agent (dSeries) CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation DE - Business Agents (dSeries)

Issue/Introduction

Some of the logs in the WA Agent don't roll over or get archived.  This can cause an issue when the log grows and is not maintained.

Environment

Release : 11.3.x, 11.4, 11.5, 12.0

Component : CA Workload Automation System Agent

Cause

The 'runner_os_component.log' is not archived in 11.x and R12.0.  It can grow if the log.level is set to 5.

Resolution

Upgrade the agent to 12.1 (or above).  This will archive or roll the agent when it reaches log.maxsize.  

If upgrade is not possible, then current workaround for 12.0 or below version is to set log.level=2 in agentparm.txt.  See this example:

log.level=5
log.archive=1
log.maxsize=1M

Note: The 11.3 and 11.4 version are out of support as Oct 2022.  It is highly recommended to upgrade to 12.0 or 12.1..

 

Additional Information

 

Log File Maintenance