Maileater Using Different Port Than Configured.
search cancel

Maileater Using Different Port Than Configured.

book

Article ID: 217900

calendar_today

Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

When trying to configure a mailbox using port 143

Errors in the maileater_nxd log show:

2021-06-21 20:44:36:648 ERROR  [ForkJoinPool-1-worker-1] c.c.S.m.c.JavaMailIMAPClient - Failed to make connection with STARTTLS to server outlook.com, port 993, trying SSL connection

2021-06-16 08:41:45:382 TRACE  [ForkJoinPool-1-worker-2] c.c.S.m.ConnectSession - [mailbox:MAILBOX:400979]  Failed to connect to IMAP4 server outlook.com at port 993

Appears even though port 993 is not configured.

 

 

Environment

Release : 17.x

Component : Service Desk Email

Mailbox in Microsoft365

Cause

STARTTLS tries to form an insecure connection first then a secure connection.

This is why we see a connection attempt using port 993. 

Port 143 is the insecure port and port 993 is the secure port. 

Resolution

If STARTTLS unsuccessfully tries to connect using IMAP insecure port 143, then by design it tries to form a secure connection using port 993.