SchedLink error while opening CA PPM Project
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SchedLink error while opening CA PPM Project

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Article ID: 217847

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

After installing or upgrading the Clarity Microsoft Project integration, this error is shown after trying to open a project from Clarity to MSP:

"SchedLink: An error occurred while opening CA PPM Project in Microsoft Project. Please try again."

Cause

One possible cause is that due to the Microsoft Project Macro Security settings, the macro that finishes installing the integration has not run yet.

Resolution

Close Microsoft Project completely if it has been started from Clarity. Then, open it again from your Start Menu and if you get a prompt, allow the execution for the macro for the add-in.

If the macro has already been blocked, re-install the integration and ensure that Macro Security level is set to 'Enable all macros', under Microsoft Project > File > Options > Trust Center > Trust Center Settings > Macro Settings. This setting can be reverted back after the add-in installation.

Additional Information

KB 45862 - Clean uninstall of the MSP interface

Techdocs: Configure the Microsoft Project Interface > Set the Trust Center Level in Microsoft Project