Search Server fails after upgrade with "CA Service Management Search Server" Service missing
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Search Server fails after upgrade with "CA Service Management Search Server" Service missing

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Article ID: 217846

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

after upgrading, Search Server is no longer running.

Search Server runs on a dedicated server normally.
After upgrading the server, Search Server log indicates no errors occurred.

Old service is removed, but "CA Service Management Search Server" Service is non-existent in the Services listings (services.msc)

Environment

Release : 17.3 RU6 and higher

Component : XFLOW INTERFACE FOR SDM

Cause

The JRE directory is missing and had failed to be created.  The installer may be failing as there may be UAC (User Account Control) in place and is restricting access to the "C:\Program Files\CA\SC" and "C:\Program Files (x86)\CA\SC" locations. 

Resolution

Before performing the following, please make sure there is a backup of the installation in place.  Ideally, if there is a snapshot of the environment prior to installing the RU, please rollback to the given snapshot first.

The following instructions are applicable for a 17.3 RU8 configuration which introduces JRE 11.0.3.  The instructions should also apply for 17.4 releases where SearchServer install update experiences a fault for the same reasons described here.  This JRE release will vary depending on the RU in question. 

Activity was performed on the dedicated Search Server server.

  1. Locate the 17.3 RU8 storage location.  Navigate to \patches\xFlow\SearchServer\17_3_0_8\Binaries and locate file SearchServer-17.3.0.8.caz

  2. Copy the SearchServer-17.3.0.8.caz file to a temp directory

  3. Navigate to \filestore\utils\ApplyPTF and locate file cazipxp.exe.

  4. Copy the cazipxp.exe file to the same temp directory where SearchServer-17.3.0.8.caz was copied.
  5. In an admin command prompt, run "cazipxp -u SearchServer-17.3.0.8.caz".  This will create several files and directories, and of particular interest is "jre_win_11.0.3.zip"

  6. In the C:\Program Files\CA\SC directory, create a directory called "JRE" if it is not already present, then in the "JRE" directory, create a directory called "11.0.3"

  7. In the temp location, unzip the "jre_win_11.0.3.zip", then copy the contents of the zip file into C:\Program Files\CA\SC\JRE\11.0.3  The directory content should look like this:



  8. If you have not rolled back to an earlier state, please uninstall Search Server (under Programs and Features) and change the al_cdb_componentinstallstate table entry for task.searchserver.patch.17.3.0.8 to a failed state.  DB Query should be:

    update al_cdb_componentinstallstate set installationstate = 'failed' where where packageid = 'task.searchserver.patch.17.3.0.8'


  9. Run the 17.3 RU8 installer as before to upgrade Search Server.  Make sure for the Shared Components directory to point to "C:\Program Files\CA\SC" and not "C:\Program Files (x86)\CA\SC"

 

Additional Information

Other steps taken which resulted in successful upgrade:

elasticsearch.yml had blank fields where the host name should be 

config.yml had a blank locale which was updated to English.

Then we rebuilt the indexes.