Error about "Account is disabled" in Performance Center console service log
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Error about "Account is disabled" in Performance Center console service log

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Article ID: 217841

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Updated On:

Products

DX NetOps CA Performance Management - Usage and Administration

Issue/Introduction

Seeing the following error message show up in the DX NetOps Performance Management (PM) Performance Center (PC) console service logs.

INFO   | jvm 1    | 2021/06/15 09:17:03 | WARN  | qtp118966853-22604       | 2021-06-15 09:17:03,203 | com.ca.im.portal.services.user.UserAuthenticationServiceImpl     
INFO | jvm 1 | 2021/06/15 09:17:03 | | Unable to determine auth type for user 'capcServiceUser' -- UserAuthentication - Account is disabled.

The errors appear in the PCService.log and the PC console (caperfcenter_console) wrapper.log log files found in the (default path) /opt/CA/PerformanceCenter/PC/logs.

Environment

All supported DX NetOps Performance Management releases

Cause

The OI Connector integrated with the Performance Management system has an issue with the Performance Center User it's configured to use for access.

Resolution

In the scenario where this error was observed the OI Connector was installed but was not in use yet. The OI Connector services were shut down and prevented from restart until ready to use the connector. This resolved the errors flooding the logs.

If the OI Connector is in use, there are few things to check that should resolve the error.

  1. Is the OI Connector User configured in Performance Center enabled? If not enable the user.
  2. Is the OI Connector User configured with the correct current password for that user? If not update the password to use the current correct value.

Additional Information

The Knowledge Base article titled DX OI integration with DX NetOps PM, CA ADA, and CA NFA - OI Connector Troubleshooting, Common Issues and Best Practices has information about setting/updating the User Name and Password for the OI Connector.