Software Content Download Job is in error after upgrade of DSM Manager
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Software Content Download Job is in error after upgrade of DSM Manager

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Article ID: 217817

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

After upgrade of DSM Manager, Software Content Download Job is in status error.

In log C:\Program Files (x86)\CA\SC\CIC\logs\CIC.log following error appears :

2021-05-27 00:10:05,482 [CCMain] INFO  [com.ca.sccc.dbm.CCDBManager] - Initializing MDB connection 'jdbc:sqlserver://SampleDomain1:1433' for domain 'SampleDomain1'. User name: user1
2021-05-27 00:10:21,639 [CCMain] ERROR [com.ca.sccc.dbm.CCDBManager] - Failed to acquire MDB connection for domain 'SampleDomain1'

Environment

Client Automation - All Versions

Cause

File C:\Program Files (x86)\CA\SC\CIC\conf\config.xml was corrupted during upgrade of DSM Manager (upgrade of CIC)

Resolution

If problem occurs after upgrade to 14.5, following solution could be applied :
 
1- Rename the file C:\Program Files (x86)\CA\SC\CIC\conf\config.xml as config.xml.ori
 
2- Copy the file C:\Program Files (x86)\CA\SC\CIC\Build 14.0.2000.199 (201703151749D)\conf\config.xml to C:\Program Files (x86)\CA\SC\CIC\conf
 
Remark :
Replace "Build 14.0.2000.199 (201703151749D)" by the correct directory name.
In this example "Build 14.0.2000.199 (201703151749D)" is a backup of CIC 14.0 SP2
 

3- Edit the file C:\Program Files (x86)\CA\SC\CIC\conf\config.xml with Wordpad and add the 2 lines connect* in <domain> section if they do not exist already :
 
      <evictIdleTime>600000</evictIdleTime>
      <evictInterval>60000</evictInterval>
      <connectRetries>3</connectRetries>
      <connectRetryInterval>300000</connectRetryInterval>
    </domain>
 
4- Execute this command to check that all is working fine :
cd E:\CA\SC\CIC\bin
run.bat
 
 
 
If problem occurs after upgrade to previous version than 14.5 (ex: upgrade 14.0 SP2 -> 14.0 SP3)
 
1- Open a DOS prompt and execute these commands : 
 
cd /D "C:\Program Files (x86)\CA\SC\CIC\bin" 
util -P SampleDomain1 
util -P 222SampleDomain2 
 
util -A mdb_server inst1:1434 s cicuser pwd_cicuser sa pwd_sa 
or
util -A mdb_server 1433 s cicuser pwd_cicuser sa pwd_sa 
 
 
Remarks : 
 
  • Replace mdb_server by the SQL ServerName hosting the mdb database

  • Replace inst1:1434 by SQL InstanceName and port or only 1433 if it is the default instance (not named).

  • Replace pwd_cicuser by a choosen password for cicuser. You could choose the password you wish. 

  • Replace pwd_sa by the password for SQL sa account 
If the password for sa is not known, this could be done :

- In Microsoft SQL Server Management Studio, open the properties of login ca_itrm (under Security/logins)

- In Server Roles, give sysadmin server role to login ca_itrm

- Execute following command line :

util -A mdb_server 1433 s cicuser pwd_cicuser ca_itrm NOT_changedR11 
 
NOT_changedR11 is the default password for ca_itrm, replace it by correct value if you have changed its password 

- Important : Remove Server Role sysadmin to login ca_itrm 
 
 
 
2- Test if it is working fine with : 
 
util -M mdb_server
and
run.bat 
 
Otherwise it is also possible to restore the file config.xml from a backup.