Password reset options for OKTA external user
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Password reset options for OKTA external user

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Article ID: 217814

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

External users (non-federated Okta users) when prompted for a password reset or post password expiry are not able to login to clarity nor set the new password even after meeting the required password rules. 

The message on the screen:

“Your password has expired

Password Requirements: minimum 8 symbols, a small cap letter, a capital letter, a number, a special character, no part of your username. You password can´t be any of your last 10 old password”.

“There was an unexpected error occurred. Please try again “


The same error was found when trying to reset the password in advance to the expiry:

Environment

Clarity PPM SAAS

Cause

As part of registration redesign phase1, there is a restriction of using the password reset using the temporary password option and can be performed only by sending password reset link to user's email address as part of employment verification process.

Resolution

User's should ideally be using Password reset self-service link : https://portal.broadcom.com/web/guest/forgotpassword

Additional Information

Okta password reset for non-fed accounts comes in following options:

  1. Customer’s designated group administrator (Okta Admin) can send reset email for user in one-time password mode (Recommended)

  2. Okta Admin can also send temp password - (User need to go through a longer procedure to reset the password as Broadcom SSO will validate the user’s email by sending a link to user’s email instead of letting user set a password directly after validating with temporary password)



  3. Uses can directly do a password reset by using the self-service link : https://portal.broadcom.com/web/guest/forgotpassword    (Best self-service option)



    User enters username and submit



    User receives an email from [email protected]



    User clicks on password reset link



    After password is set user is taken to support portal.


  4. Users reset password via Okta Dashboard (self-service)





    A email reset link will be sent to user email and password can be reset from the link.


  5. Users visit Broadcom portal

    Select “Forgot Username/Password” link




    OR

    Click "Need help signing in?" option and click forgot password link



Note: in situations where user is not able to get emails when the email addresses are valid , customers group admin can try sending reset password link via email.

Broadcom don't want admins resetting password and sharing with end user offhand and want to make sure user's email is validated.