How are timeouts for external attributes handled from CLI?
search cancel

How are timeouts for external attributes handled from CLI?

book

Article ID: 217718

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

I have built a script where attributes are queried from certain devices.
In OneClick the attribute is displayed, but it happens that via the CLI the attribute is not displayed, so it is empty.

Is there a setting to change the timeout of the query?

Environment

Release : 20.2, 10.x

Component : Spectrum Core / SpectroSERVER

Cause

External attributes are being polled upon demand and goes through the SpectroSERVER.

Resolution

Adjusting the DCM Timeout value on the device (to a higher value),  will extend the duration of polling for the device when external attributes are being used with CLI.