O365 Mailbox Not Connecting With Verified Settings
search cancel

O365 Mailbox Not Connecting With Verified Settings

book

Article ID: 217620

calendar_today

Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

Maileater_nxd.log shows logs similar to:

ERROR  [ForkJoinPool-1-worker-0] c.c.S.m.c.JavaMailIMAPClient - Failed to connect to the Store.
javax.mail.AuthenticationFailedException: AUTHENTICATE failed.
 at com.sun.mail.imap.IMAPStore.protocolConnect(IMAPStore.java:725)
 at javax.mail.Service.connect(Service.java:366)
 at javax.mail.Service.connect(Service.java:246)
 at com.ca.ServicePlus.mail.connection.JavaMailIMAPClient.connectToStore(JavaMailIMAPClient.java:147)
 at com.ca.ServicePlus.mail.connection.JavaMailIMAPClient.initializeClient(JavaMailIMAPClient.java:135)
 at com.ca.ServicePlus.maileater.ConnectSession.Hunny_Connect(ConnectSession.java:260)
 at com.ca.ServicePlus.maileater.ConnectSession.Connect(ConnectSession.java:156)
 at com.ca.ServicePlus.maileater.ConnectSession.check_mail(ConnectSession.java:178)
 at com.ca.ServicePlus.maileater.IMAP4EmailClient.check_mail(IMAP4EmailClient.java:138)
 at com.ca.ServicePlus.maileater.Mailbox.lambda$new$1(Mailbox.java:822)
 at java.util.concurrent.ForkJoinTask$AdaptedCallable.exec(Unknown Source)
 at java.util.concurrent.ForkJoinTask.doExec(Unknown Source)
 at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(Unknown Source)
 at java.util.concurrent.ForkJoinPool.runWorker(Unknown Source)
 at java.util.concurrent.ForkJoinWorkerThread.run(Unknown Source)
TRACE  [ForkJoinPool-1-worker-0] c.c.S.m.ConnectSession - [mailbox:MAILBOXNAME:400979]  Failed to connect to IMAP4 server outlook.com at port 993

This is generic and doesn't give us very much information. 

Reference Failed to Connect to the Store Error, AUTHENTICATE failed error in maileater_nxd Logs when using an Office365 account to ensure the configuration is correct.

Then look in Azure logs under Azure Active Directory > Monitoring > Sign-ins

Look for email box user name and Application "Office 365 Exchange Online"

 

Environment

Release : 17.x

Component : Svc Desk Email

Mailbox in Microsoft365

Cause

Conditional Access Policy is misconfigured or not configured at all

Sign-ins log shows:

Status: Failure

Failure Reason:  Access has been blocked by Conditional Access policies. The access policy does not allow token issuance.

 

Resolution

Mailboxes were not authenticating because there was no Conditional Access Policy created in Azure.

Have customers Azure Team Create an appropriate Conditional Access Policy for the mail user account under:

 

 

Attachments