Use End User's Timezone is ignored for a Service Type
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Use End User's Timezone is ignored for a Service Type

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Article ID: 217507

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Unexpected behavior with the following scenario:

  1. Set Windows Server as GMT;
  2. Set SDM Server as GMT;
  3. Go to "Priority 3 Resolution" service type;
  4. Set the "Workshit" as Regular;
  5. Set Timezone as EU which is GMT + 1;
  6. Deactivate all events and keep only "priority 3 resolution violation";
  7. Set Delay Time as "2 hours";
  8. Go to the "Applications" area;
  9. Set "Service Type" as "Priority 3 Resolution";
  10. Go to options manager;
  11. Make sure "set_sla_evt_open_date" and "sla_workshift_override" is installed;
  12. Restart SDM (just in case - because of the options manager);
  13. Create an incident and set the category as "Applications" at time 22:00 on Monday;
  14. As per the existing design, the event fire time is calculated as 10:00 (GMT) of Tuesday of server time. (This is calculated based on ticket creation time, workshift ay 8 AM to 5 PM). This is equivalent to 11:00 EU (GMT + 1).

Expected behavior should be:

The event file time should be calculated as 10:00 (EU: GMT + 1) based on Service Type Time Zone, and which should be equivalent to 09:00 (GMT) of the server time.

The documentation below also presents a scenario:

Time Zone Setup

Environment

CA Service Desk 17.1 and higher.

Cause

The OOTB Service Type "Priority 3 Resolution" has "Use End User's Timezone"(use_cnt_tz) set as "No" as seen from the web interface.

Its value is actually NULL in the database.

The code checks whether the use_cnt_tz is 0 or 1. Since the value is NULL, nothing gets resolved, and always the server time is being taken.

Resolution

It is being addressed by engineering, but in the meantime, please, implement the following workaround:

  1. Edit the service type and set the 'Use End User's Timezone' as Yes and save it;
  2. Re-edit the service type again and Uncheck the setting and save the page so that the value in the database now gets saved to 0;
  3. This is to ensure the value gets saved to 0 instead of NULL;
  4. This resolves the issue you see and the Service Types Timezone will be considered when the event is triggered. 

Additional Information

Defect DE59765