Mac Agent install works but does not connect to the server
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Mac Agent install works but does not connect to the server

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Article ID: 217501

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Updated On:

Products

Data Loss Prevention Enterprise Suite

Issue/Introduction

After install the Mac agent it fails to connect to the server. This same package has been used successfully on other mac machines.

When reviewing the log files on the agent we see the following messages:

File: edpa_ext0.log
Date: 6/4/2021 11:06:05 AM
Thread: 47461
Level: INFO
Source: AgentService.KernelMessageService
Message: FSD could not be loaded due to system policy,Retrying to load FSD Kext...

File: edpa_ext0.log
Date: 6/4/2021 11:06:08 AM
Thread: 47461
Level: WARNING
Source: AgentService.KernelMessageService
Message: FS driver load failed: /Library/Manufacturer/Endpoint Agent/fsd.kext : (libkern/kext) system policy prevents loading

File: edpa_ext0.log
Date: 6/4/2021 11:06:08 AM
Thread: 47461
Level: SEVERE
Source: AgentService.KernelMessageService
Message: Failed to load /Library/Manufacturer/Endpoint Agent/fsd.kext, driver load state is 2 [SYMRESULT 0x80010005]

Environment

Release : 15.7 MP1 and below

 

Cause

Unsupported version of DLP on OSX 11.x

Resolution

This is a known limitation with OSX 11.x and above. Please upgrade to DLP 15.7 MP2 or greater as earlier versions are not supported on OSX 11. See macOS operating system requirements for endpoint systems in the system requirements guide for further details.