Spectrum server events not available
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Spectrum server events not available

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Article ID: 217480

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Updated On:

Products

CA Spectrum

Issue/Introduction

Spectrum production server all events not available 

 

Environment

Release : 20.2.x

Component : Spectrum Alarm & Event Management

Cause

Communication is not happening between Spectroserver and Oneclick server

Resolution

Check ARCHMGR.OUT (%SPECROOT%\SS\DDM) is not showing any error

Check VNM.OUT (%SPECROOT%\SS) not showing any error related to Archmgr

Check in Spectrum Control Panel whether Archmgr shown as running
if it is showing it as running

Still in Oneclick Console events are shown red

Check whether oneclick is able to connect to ArchMgr on port 14003

                  telnet SS-IP 14003

If this is shown as connected

Stop tomcat service 

bash -l
cd tomcat/bin
./stopTomcat.sh

Stop processd service

Switch User to root
su 
cd %SPECROOT%\lib\SDPM 
./processd --stop


start processd 

Ensure that you logged in as root

su
cd %SPECROOT%\lib\SDPM
./processd --start


Start tomcat service

switch user to spectrum install user
  su {install user}
  cd %SPECROOT%\tomcat\bin
./startTomcat.sh

Wait for 10-15 minutes for tomcat to start

Login to Oneclick console

check the connection status -> Events
It should be shown as green now and you should be able to see the events

if still problem persists please open a case with support to troubleshoot further.

Additional Information