Renaming folder fails during installation
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Renaming folder fails during installation

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Article ID: 217463

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

During a fresh install of Service Desk 17.3 OR an upgrade, the install/upgrade fails during the Pre-configuration Steps for CA Service Desk Manager Updates(s).

The error message is:

jdk_x64_windows_hotspot_11.0.3_7.zip, dir=, relPath=, _switch=, type=jreupgrade, source=patches\common, version=11.0.3, use64BitPath=false]

Error inside of the Install.log

DEBUG [AWT-EventQueue-0] [PostInstallUtilFactory] inside getPostInstallAction method
DEBUG [AWT-EventQueue-0] [PostInstallUtilFactory] Adding action for type : jreupgrade
DEBUG [AWT-EventQueue-0] [DeployThread] >> Adding Pre Configurtion: PreConfigureXmlAction [ PreConfigureXmlAction=Action [content=OpenJDK11U-jdk_x64_windows_hotspot_11.0.3_7.zip, dir=, relPath=, _switch=, type=jreupgrade, source=patches\common, version=11.0.3, use64BitPath=false ]]

INFO  [DeployThread: Running Pre Configuration steps for CA Service Desk Manager Update(s) : 17.3] [PatchUtil] Extracting source package from 'C:\Users\<userid>\AppData\Local\Temp\2\\OpenJDK11U-jdk_x64_windows_hotspot_11.0.3_7.zip' to 'D:/Program Files (x86)/CA/SC\JRE'
INFO  [DeployThread: Running Pre Configuration steps for CA Service Desk Manager Update(s) : 17.3] [PatchUtil] zip file extracted from ' C:\Users\<userid>\AppData\Local\Temp\2\\OpenJDK11U-jdk_x64_windows_hotspot_11.0.3_7.zip ' to : D:/Program Files (x86)/CA/SC\JRE
DEBUG [DeployThread: Running Pre Configuration steps for CA Service Desk Manager Update(s) : 17.3] [PatchUtil] Renaming the folder from : D:/Program Files (x86)/CA/SC\JRE\jdk-11.0.3+7/ to D:/Program Files (x86)/CA/SC\JRE\11.0.3
DEBUG [DeployThread: Running Pre Configuration steps for CA Service Desk Manager Update(s) : 17.3] [PatchUtil] Renaming the folder failed... Retrying
ERROR [DeployThread: Running Pre Configuration steps for CA Service Desk Manager Update(s) : 17.3] [PatchUtil] Exception occurred while renaming the folder D:\Program Files (x86)\CA\SC\JRE\jdk-11.0.3+7 -> D:\Program Files (x86)\CA\SC\JRE\11.0.3
INFO  [DeployThread: Running Pre Configuration steps for CA Service Desk Manager Update(s) : 17.3] [JREUpgrade] ********** Upgrade of SDM JRE Completed **********

DEBUG [DeployThread: Running Pre Configuration steps for CA Service Desk Manager Update(s) : 17.3] [JREUpgrade] retValue = -1
DEBUG [DeployThread: Running Pre Configuration steps for CA Service Desk Manager Update(s) : 17.3] [PreConfigurationBase] Return result from execute of jreupgrade is  success ? :false

Environment

CA SERVICE DESK MANAGER version 17.3 and higher

 

Cause

Unable to extract file contents from its current location.  Insufficient permissions for rename.

Resolution

Verify that 8dot3 notation is enabled. 

8dot3 name creation

Go to the location of your JDK folder and copy the contents of the JDK folder created to a new folder inside of the JRE folder name the folder 11.0.3.  Click Retry.

Renamed the folder from C:\Program Files (x86)\CA\SC\JRE\jdk-11.0.3+7/ to C:\Program Files (x86)\CA\SC\JRE\11.0.3.

Additional Information

Renaming attempts may also fail if there is insufficient permissions in place to allow a folder rename to occur.  This has been seen with some Tomcat implementations, and present in the install.log as this:

ERROR [DeployThread: Running Pre Configuration steps for CA Service Desk Manager Update(s) : 17.3] [PatchUtil] Exception occurred while renaming the folder F:\Program Files (x86)\CA\SC\tomcat\apache-tomcat-8.5.43 -> F:\Program Files (x86)\CA\SC\tomcat\8.5.43

One may consider examining if the installer was being performed by a user with Admin access or if the given folder was subject to any security rules, from virus protection, anything OS specific.  Additionally, there may have been a setting that would disallow a rename of the folder unless it was being done interactively. ie:  a script or process based rename may be blocked by an OS security policy.