Manually purge campaign on Oracle Database
search cancel

Manually purge campaign on Oracle Database

book

Article ID: 21738

calendar_today

Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

Problem:

The campaign data purge from the RCM portal takes a while to complete and is resource intensive.

The script performs the same action in a considerable less time and resources.

Environment:

GM 12.6 SP4/ Oracle DB

Cause: 

Due to large dataset

Resolution:

Here are the steps to running the script:

  1. Stop RCM server
  2. Run the following sql query to get the BusinessFlows: "select * from businessflows;"
  3. The result is a list of all the business flows, note BUSINESSFLOWID of the campaign you wish to purge. For this document we will assume it is 42.
  4. Open the jar file dbutil-jar-with-dependencies.jar locaterd in <RCM_Home>/eurekify-jboss/bin/ for JBoss and for WebSphere
  5. In the navigate to com\eurekify\dbutil\oracle\sql, where you will find the file purgeCampaignScript.sql
  6. Copy the file to a different location.
  7. Open the file in a text editor and edit the first line as follows (you only need to edit the value you found in step 3):
    "DECLARE BusinessFlow_Id INTEGER := 42;"
  8. Execute the updated script.
  9. Run statistics on the schema.
  10. Start RCM server.

Environment

Release: CAIDMB99000-12.6-Identity Manager-B to B
Component:

Attachments

1558535032871TEC562657.zip get_app