After LiveUpdate Administrator upgrade, Apache service does not start
search cancel

After LiveUpdate Administrator upgrade, Apache service does not start

book

Article ID: 217224

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

Upgrading LiveUpdate Administrator from a previous version, the LUA Apache service does not start. 

Cause

During the upgrade a service.bat is run to uninstall the old service and install the new service.

If this fails, it is not logged, though it is evident if the Apache Tomcat Server version is not updated to the latest version. For example with LUA 2.3.9, this should be reflected as "Apache Tomcat 8.5.56 Server - https://tomcat.apache.org/" in the Description of the properties of the service. 

Resolution

From an elevated command prompt, go to C:\Program Files (x86)\Symantec\LiveUpdate Administrator\tomcat\bin and execute the following commands:

  1. service.bat uninstall
  2. service.bat install

Then start the LUA Apache Tomcat service in services.msc