FastDataMasker Stopped working after we tried changing the default save directories
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FastDataMasker Stopped working after we tried changing the default save directories

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Article ID: 217197

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

We are currently using FastDataMasker 4.9.0.0 for our masking jobs. To simplify the Masking configuration we tried changing the default save directories to the path where we are storing our Audit files and Log files, by going to Settings - Set Default Directories in the FDM UI.

And changed the directories to be D:/CATDM/Masking

After making the changed we started seeing our masking jobs erroring out, with the following error:

Error backing up existing mapping CSV 
The system cannot find the path specified 

We are using the following Options:

AUDIT=ROW100
AUDITDIR=D:\CATDM\Masking\SQL_Masking\GW_CM\Audit
AUDITFILE=GW_CM_Postalcode1_Script_AUDIT_JAN2021Test.csv
BATCHSIZE=500000
BLANKSASNULLS=Y
CHUNKSIZE=500000
COMMIT=500000
DBUPDATES=Y
EMPTYASNULL=Y
FETCHSIZE=500000
GETTABLEROWCOUNTS=N
LARGETABLESPLITENABLED=Y
LARGETABLESPLITSIZE=2000000
LOGDIR=D:\CATDM\Masking\SQL_Masking\GW_CM\Logs
LOGFILENAME=GW_CM_Postalcode1_Script_Log_JAN2021Test.txt
ORDERBY=N
PARALLEL=80
SEEDTABLEINDEXCOLUMN=rl_rn
TRIMMEDHASHLOV=Y 

We don't understand why the error is happening, since this is the directory we are already saving our files in. We know that there isn't a permissions issue. Where do the files get stored by default? How do we resolve this issue?

 

Environment

Release : 4.9.1

Component : Fast Data Masker

Cause

By default, FDM stores the saved files in C:\Users\<useraccount>\AppData\Roaming\Grid-Tools\FastDataMasker. When the first masking job runs, FDM creates the following directories:

  • audits (default directory where audit logs are stored)
  • backups (default directory where backups are stored)
  • errorlogs (default directory where error logs are stored)
  • logs (default directory where job logs are stored)

Unless otherwise specified, FDM will try using the default directories. If the default directories are missing or unavailable, you will see this error. 

Resolution

 

I see in the Options file that you specifically set the location of the AUDITDIR and LOGDIR, so FDM by default is expecting to save the backup file in the default directory path.

To resolve the issue:

  1. Try setting the FDM Option 'BACKUPDIR' to a valid location, such as D:/CATDM/Masking/SQL_Masking/GW_CM/Backup
  2. Or recreate the C:\Users\<Useraccount>\AppData\Roaming\Grid-Tools\FastDataMasker\backups directory.

NOTE: When changing the default save directories,  FDM will create a backup directory at <Default_Save>\Logs\FastDataMasker\backups directory.