Could not read CONTACT_STATUS message in tomcat logs
search cancel

Could not read CONTACT_STATUS message in tomcat logs

book

Article ID: 217160

calendar_today

Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction


We found these messages in Tomcat Log - stdout.log. Are they a problem?

May 28, 2021 01:24:07.581 (SRM/DeviceModelPoll/updates) (AssetManagerLogging) - (ERROR) - Could not read CONTACT_STATUS (0x110ed) from device model 0x44c41f

May 28, 2021 14:19:09.659 (SRM/DeviceModelPoll/updates) (AssetManagerLogging) - (ERROR) - Could not read CONTACT_STATUS (0x110ed) from device model 0x40973a

May 29, 2021 07:04:11.899 (SRM/DeviceModelPoll/updates) (AssetManagerLogging) - (ERROR) - Could not read CONTACT_STATUS (0x110ed) from device model 0x4a4f48

May 30, 2021 07:09:14.792 (SRM/DeviceModelPoll/updates) (AssetManagerLogging) - (ERROR) - Could not read CONTACT_STATUS (0x110ed) from device model 0x4b1d15

 

Environment

Release : 20.2, 21.2

Component : Spectrum Reporting

Cause


SRM depends on the model's contact_status attribute value. It will not update devices that are not reachable.

Resolution


1. Check whether the same model appears repeatedly through the entire log, on similar messages. If not, it could have been a one time issue which was resolved on next synchronization.

2. Check device status in OneClick. The attribute is named as dev_contact_status (0x110ed). For this select the device in OneClick, or search it in Locater by the model_handle. Select the device in Exporer, and under component details view, select the Attributes tab. Look for  0x110ed, double click it to move it to the right panel, and check its value. 1, means it has been contacted, 0 means is not. If you find the device is like on below images, that would explain the message seen in Tomcat logs

Additional Information


Asset Information subview attributes not updated in Spectrum SRM for VMware ESX containers

https://knowledge.broadcom.com/external/article?articleId=196435