When downloading a patch from CA Patch Manager - Patch Packaging fails with "Verification Failed"
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When downloading a patch from CA Patch Manager - Patch Packaging fails with "Verification Failed"

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Article ID: 21715

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Patch Manager

Issue/Introduction

Every CA Patch Manager Patch has a checksum value that CA attaches to the Patch (Stored MD5 checksum).

If the vendor changes the Patch the checksum CA attaches might not match the actual vendor checksum (Generated MD5 Checksum).                                   

so, if  the <Stored MD5> checksum does not match the <Generated MD5> checksum, the Patch will fail.

What do If my patch goes to Packaging Failed and in the logs I see the following errors ? 

DEBUG Stored MD5: <Stored MD5>       
DEBUG Generated MD5: <Generated MD5>
ERROR Patch: <Patch name> verification Failed

 

Environment

 CA Client Automation Patch Manager - All versions

Cause

If you see this error on all patch download attempts, the issue is likely network related and the use of products like Web Sense or Bluecoat should be investigated.

 

Resolution

If however you only see this on a couple of patches, the below can be tried, however CA SUPPORT SHOULD BE NOTIFIED as a change may need to be made to published patches for all clients.


To solve this problem, we are going to change the Stored MD5 checksum for this patch, to make it match the Generated MD5 Checksum Value that the patch expects.


 

1.  First, use the download URL listed in the patch to ensure the patch is actually downloading correct and is functional. If so we can proceed.


Click on Patch >  Select Files > Click on the File that is giving you the checksum issue> select Download URL and try to download the patch.





 

Check UPM.LOG(pre-R14)   or PMEngine.log(R14 and above) for lines like the following:


Sample Data:


DEBUG [com.ca.unicenter.upm.dlm] - Stored MD5: aa939ff0fc9915f1b34c10e73e310195
DEBUG [com.ca.unicenter.upm.dlm] - Generated MD5: 813ad3f2186c75d7019efe36b90a55ff
ERROR [com.ca.unicenter.upm.dlm] - Patch: jre-6u18-windows-i586.exe {a8737c11-03f8-4625-8a3a-5e04efa8d6ad} verification failed

Open SQL as an admin.
Create a new Query


First find the entry in question.
Generically the query would be as follows:


use mdb
select checksum, name from ca_download_file
where name like '%<patch-name>%'

For our example, you can run the following query and confirm you receive one result.


This should list the patch-name, and the Generated MD5 checksum needed.


use mdb
select checksum, name from ca_download_file
where name like '%jre-6u18-windows-i586.exe%'

For the next query we will change the Generated MD5 checksum to match the Stored MD5 checksum.


Generically the query would be:


use mdb
Update ca_download_file
set checksum='<Stored MD5 checksum>'
where name='<Patch Name>'

In our example the Query will be as follows:


use mdb
Update ca_download_file
set checksum='813ad3f2186c75d7019efe36b90a55ff'
where name='jre-6u18-windows-i586.exe'

You are now ready to Accept the Patch again.


It should now Package and Verify successfully.