Data not coming in report
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Data not coming in report

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Article ID: 217109

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Updated On:

Products

CA Performance Management - Usage and Administration

Issue/Introduction

data not coming in any report including self monitoring dashboards

Environment

Release : 20.2

Component : PERFORMANCE MANAGEMENT INTEGRATIONS

Cause

as per the pcservice.log

ERROR | Status Poller-thread-1   | 2021-06-09 00:00:07,272 | com.ca.im.portal.services.syncstatus.GlobalSyncStatusDAO
      | An error occurred retrieving global sync status.
org.springframework.jdbc.UncategorizedSQLException: PreparedStatementCallback; uncategorized SQLException for SQL [SELECT DISTINCT gsl.SyncTime, gsl.StageName, gsl.StartTime, gsl.EndTime, gsl.Status, gsl.ErrorMessage FROM global_sync_log gsl WHERE gsl.SyncTime=(SELECT max(SyncTime) FROM global_sync_log) ORDER BY gsl.StartTime, gsl.EndTime]; SQL state [HY000]; error code [145]; Table './netqosportal/global_sync_log' is marked as crashed and should be repaired; nested exception is java.sql.SQLException: Table './netqosportal/global_sync_log' is marked as crashed and should be repaired

global_sync_log table crashed.

 

Resolution

Login to CAPC server

 

Stop Below services

Service caperfcenter_console stop

Service caperfcenter_devicemanager stop

 

Repair the corrupted table

cd /opt/CA/MySql/bin (Path might change basing on your install)

mysqlcheck -pPASSWORD -r netqosportal

netqosportal.global_sync_log
warning  : Number of rows changed from 419727 to 419709
status   : OK

Status should turn OK 

 

Start below services

Service caperfcenter_console start

Service caperfcenter_devicemanager start