Settings in Endevor not being saved all the time to the ISPF Profile dataset (ISPPROF)
search cancel

Settings in Endevor not being saved all the time to the ISPF Profile dataset (ISPPROF)

book

Article ID: 217041

calendar_today

Updated On:

Products

Endevor

Issue/Introduction

Time to time a user will complain that values are not being saved from TSO session to session. These values are in Quick Edit Action Options, Dialog Defaults and location settings. In Classic Endevor it can be location settings and any setting that is set by the ISPF Config Table(ENDICNFG). Why is this happening?

Environment

Release : all

Component : CA Endevor Software Change Manager

Cause

Endevor Saves ISPF settings to the ISPF Profile. This is controlled by the active APPLID. Look at the Endevor startup CLIST to find the APPLID.

If the APPLID is CTLI then the information is stored in 3 members in your ISPPROF dataset. In this case they would be CTLIEDIT, CTLIEDRT and CTLIPROF.

The setting information for the user's session is saved when the APPLID is ended. So when Endevor is exited.  

Resolution

This would be a ISPF issue more than a Endevor issue. Here are a few reasons that it may be happening:

  1. The user does not exit Endevor at the end of the day. So session is timed out or canceled. This would cause any change to the profile to be lost.
  2. The APPLID is shared with another ISPF application or option. This can cause members to be overwritten or delay the closing of the APPLID.