Not all transactions are being captured during a transaction trace session
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Not all transactions are being captured during a transaction trace session

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Article ID: 217008

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Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope) DX APM SaaS DX Application Performance Management CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management SaaS

Issue/Introduction

We tried validating this by running transaction trace session from workstation to capture and trace the requests having slowness. In our test, we know the service which is taking more than 10 seconds to respond. However, we are unable to capture this with transaction trace session.

We could see only traces for 2 other services  during entire test run.

 

Environment

Release : 10.7.0, 20.x

Component : Integration with APM

Cause

The agent log contained the following messages

[WARN] [IntroscopeAgent.Agent] Absolute metric clamp of 5000 reached, no more metrics can be created. Instrumentation on this application should be reduced

[INFO] [IntroscopeAgent.Agent] The Agent Transaction Trace limit (introscope.agent.ttClamp) of 50 transactions every interval has been reached. No more transactions traces will be reported for this interval..

The first clamp is the most likely reason for this transaction not being traced - if a metric cant be reported it cannot be included in a trace.

Resolution

In the IntroscopeAgent.profile, you can adjust the following property to increase the number of metrics the agent can report

introscope.agent.metricClamp=