Protection Engine service fails to start "failed to find supported version of java"
search cancel

Protection Engine service fails to start "failed to find supported version of java"

book

Article ID: 216963

calendar_today

Updated On:

Products

Protection for SharePoint Servers Protection Engine for Cloud Services Protection Engine for NAS

Issue/Introduction

On Windows, the service for Symantec Protection Engine (SPE) fails to start with error 1053. SymantecProtectionEngineAbortLog.txt indicates:

100 Java virtual machine failed to load : CJNIBridge: failed to find supported version of java..
0 Symantec Protection Engine is shutting down; logs may contain more information.

Cause

The RestApi is enabled and SPE cannot find an appropriate version of Java.

Resolution

To resolve this issue:

    1. Verify that a supported version of Java is installed using this document: https://knowledge.broadcom.com/external/article/157789/
    2. Verify the JavaLocation is correct in the <SPE_INSTALL_FOLDER>/configuration.xml
      • Windows default location: C:\Program Files\Symantec\Scan Engine\
      • Linux default location: /opt/SYMCScan/bin

Note: If the JavaLocation is "", then SPE uses the environment variable for the Java install location

    • Windows: Java_Home
    • Linux: Path

Additional Information

Q: Do I have to install Java to manage SPE?

A: SPE uses Java for the SPE 9 RestApi, which listens for connections from the SPE 9 console. However, SPE can be managed from the local command line completely without the SPE console. See the following page for more information:

https://techdocs.broadcom.com/us/en/symantec-security-software/endpoint-security-and-management/symantec-protection-engine/9-3-0/Core-server-only-mode/about-the-core-server-only-mode-v128491244-d4995e18688.html