Protection Engine service fails to start "failed to find supported version of java"
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Protection Engine service fails to start "failed to find supported version of java"

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Article ID: 216963

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Updated On:

Products

Protection for SharePoint Servers Protection Engine for Cloud Services Protection Engine for NAS

Issue/Introduction

Symantec Protection Engine (SPE) fails to start with error 1053. SymantecProtectionEngineAbortLog.txt indicates:

2021/06/08-15:57:53 100 Java virtual machine failed to load : CJNIBridge: failed to find supported version of java..
2021/06/08-15:57:53 0 Symantec Protection Engine is shutting down; logs may contain more information.

Cause

The Java console is enabled and SPE cannot find an appropriate version of Java.

Resolution

You can either ensure an appropriate version of Oracle Java is installed and that SPE can find it, or you disable the Java console and manage SPE from the command line.

Pointing SPE to appropriate Java

  1. Ensure a compatible version of Oracle Java is installed. See the Java support matrix:
  2. Make sure SPE can find the Java binaries. This is different depending on OS.
    1. Windows: The directory with the Java binaries should be included in the System's PATH variable


    2. Linux: Open <install dir>/bin/symcscan.sh in a text editor and set the JavaJRELib variable to the path for the directory that contains the Java binaries

Disabling the Java console

See the following article for instructions on disabling the Java console:

https://knowledge.broadcom.com/external/article/155541/

Additional Information

Java can be managed completely without the Java console. See the following page for more information:

https://techdocs.broadcom.com/us/en/symantec-security-software/endpoint-security-and-management/symantec-protection-engine/8-2/Core_server_only_mode_10/about-the-core-server-only-mode-v128491244-d4995e18688.html

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