search cancel

Timesheet stuck in 'Approved' status with error "ORA-01722: invalid number"

book

Article ID: 216799

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

After Approving a Timesheet and then attempting to post it by running the Post Timesheet job, the following error gets generated in the bg-ca.log file.

ERROR 2021-04-14 11:35:04,445 [Dispatch Post Timesheets : [email protected] (tenant=clarity)] xql2.xbl (clarity:admin:48401197__142B4018-4727-4C5F-AE2D-9CCDF1AA7377:aPost Timesheets) ****POSTTIMESHEET: Error posting timesheet - unknown error-->timesheetID=6234114
java.lang.Exception: Failure while evaluating "not setActThru('assignment', 'task',  'calendar', 'project', timesheet.prStart, timesheet.prFinish, 'siteCal', $isAdjustment)" in expression "{not setActThru('assignment', 'task',  'calendar', 'project', timesheet.prStart, timesheet.prFinish, 'siteCal', $isAdjustment)}" error: java.sql.SQLDataException: [CA Clarity][Oracle JDBC Driver][Oracle]ORA-01722: invalid number

Caused by: java.lang.RuntimeException: java.sql.SQLDataException: [CA Clarity][Oracle JDBC Driver][Oracle]ORA-01722: invalid number

Environment

Release : 15.8.1, 15.9.1

Cause

This is caused by the the Actuals Cost curve in Prassignment table being corrupt

Resolution

Contact Broadcom technical support to assist in running Cstools script to repair actcost curve in the Prassignment table.

Additional Information

If the above doesn't help, see also: Approved timesheets not posting - master KB of known issues