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Unable to start tests or load reports - Intermittent issue

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Article ID: 216688

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Updated On:

Products

BlazeMeter

Issue/Introduction

In a Private Cloud environment, it occurred that tests could not be started and reports could not be loaded.

Tbe bzm-app (data router) log shows at the time of failure:

"An error occurred (InternalError) when calling the GetObject operation (reached max retries: 4): We encountered an internal error."

So it seems the bzm-app was not able to get an S3 object, not even after retrying 4 times.

Environment

BLAZEMETER PERFORMANCE TESTING

Cause

Since the error was intermittent and lasted only for about 10-20 minutes, it is very unlikely that there was a problem with a specific S3 object. If there was, the problem would not have solved itself without making any changes to the S3 storage. Probably there was an internal network problem that prevented the bzm-app to fetch an object in a timely manner.

Resolution

After the network problem was cleared, bzm-app was able to fetch the object and reports could again be viewed and tests started (without anything changing in S3).