Web Portal Connection to (hostname) failed.
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Web Portal Connection to (hostname) failed.

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Article ID: 216346

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

When attempting to use a TCP/UDP Web Portal service with session recording the PAM end-user gets the following error:

Web portal connection to "(hostname)" failed.

Network mount for session recording unavailable.

 

 

 

Environment

Release : 3.4.x, 4.1.x

Component : PRIVILEGED ACCESS MANAGER

Cause

Very big NFS filesystem

Resolution

Ultimately the root cause is the NFS filesystem that all PAM Appliances are writing to, had close to a million files in it.  Archiving a lot of the session recordings and the performance increased.

 

Additional Information

Even though Linux and Windows session recording were successful to the same mounted NFS directory, the creation and validation of the session recording happens in the allotted 20 seconds.

However since the Web Portal is graphical, the initial file is bigger and the creation and validation took over 20 seconds to create and validate, therefore the error.

Also Redhat documents that filesystems shouldn't have more than 100,000 files in one directory:

https://access.redhat.com/solutions/901273