Fixing Unified Management Console corruption caused by upgrading or installing with User Access Control active
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Fixing Unified Management Console corruption caused by upgrading or installing with User Access Control active

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Article ID: 216330

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Updated On:

Products

Data Center Security Server Advanced Data Center Security Server Data Center Security Monitoring Edition

Issue/Introduction

When upgrading or installing Data Center Security without disabling User Access Control, some of the required files for the UMC may not be expanded properly.  Symptoms of this may include a perpetually spinning loading circle, 404 errors in the developer tab of your browser indicating missing files, and a blank screen.

Environment

Data Center Security (DCS) 6.7.x, Data Center Security (DCS) 6.8.x, Data Center Security (DCS) 6.9.x

Data Center Security Monitoring Edition
Data Center Security Server
Data Center Security Server Advanced

Cause

UAC being active has been linked to a problem with the .WAR files (ZIP archives containing the UMC's files) not being expanded properly in place.  

Resolution

Make a copy of the following directories, then delete them:

  • <installpath>\Data Center Security Server\Server\tomcat\symapps\umc\webportal
  • <installpath>\Data Center Security Server\Server\tomcat\symapps\umc\umcservices

Finally, extract <installpath>\Data Center Security Server\server\tomcat\symapps\console\sis-ui\download\dcss.zip to <installpath>\Data Center Security Server\Server\tomcat\symapps\umc\webportal\client\src\app

This final one is the least intuitive but is a necessary step.

Once you've extracted the above files to those locations (choosing to overwrite files when given the option), restart the Data Center Security Manager service, wait 5 minutes for it to start up, then test the UMC.