search cancel

Creating a Risk on Ideas in New UI Fails with "System error. Contact system administrator."

book

Article ID: 216304

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

SUMMARY: After upgrade to 15.9.2 unable to create Risks for Idea, Projects and Custom Investments

STEPS TO REPRODUCE: 

  1. Login to MUX and navigate to Ideas
  2. Create new or use one of the existing ideas
  3. Click on Risks tab and attempt to create a risk
  4. Observe System error. Contact system administrator.

Note: Same issue when creating Risks from projects and CIT, as well as from Classic from Projects

Expected Results: Should be able to successfully create Risks

Actual Results: Unable to create Risk, getting system error and you can see the below errors in app ca logs 

  • Error while creating risk from Modern ux 

ERROR 2021-05-19 16:28:26,286 [http-nio-80-exec-94] niku.xql2 (clarity:admin:43170497__E69EA1C3-4047-4BED-86C4-B50E5794F971:PPM_REST_API) Internal Processing exception
com.niku.union.persistence.PersistenceException: 
SQL error code: 0
Error message: ERROR: syntax error at or near "="
Position: 28
Executed:update INV_INVESTMENTS set =? where ID=? 

  • Error while creating risk from Classic UX 

ERROR 2021-05-19 15:43:48,056 [http-nio-80-exec-80] niku.xql2 (clarity:admin:43170497__E69EA1C3-4047-4BED-86C4-B50E5794F971:itl.riskObjectInsert) Internal Processing exception
com.niku.union.persistence.PersistenceException: 
SQL error code: 0
Error message: ERROR: syntax error at or near "="
Position: 25
Executed: update SRM_PROJECTS set =? where ID=? 

 

Environment

Release : 15.9.2

Component : CA PPM SAAS STUDIO

Cause

This is a defect DE60991

Resolution

  • The defect DE60991 is fixed in 15.9.3, 15.9.2 patch 1 as well as 15.9.2 pre-patch (GCP SaaS)