Getting a Timeout on Virtual Service intermittently from the application side
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Getting a Timeout on Virtual Service intermittently from the application side

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Article ID: 216299

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Updated On:

Products

Service Virtualization

Issue/Introduction

 

When executing transactions from client application against different types of VIrtual services such as:
- CICS Virtual Service
- HTTP Virtual Service (REST/SOAP)

From the application side, you will see errors such as:
For CICS Virtual Service:
the CICS virtual service seeing the Error EIBRESP: 0016 EIBRESP2: 0500 on the MainFrame side and seeing the error "ITKO0124 - ITKO Agent response timeout for Token xxxxxxxxxxxxxxxx." in the application log.

Note:
When VSE is restarted we are not getting the timeout but facing timeout on the application side when the CICS VS is redeployed from Workstation OR Stop/Start the VS in DevTest Portal OR Remove the VS and Upload the MAR file to VSE in Portal OR leave the working VS for a couple of hours or all night and then hit the VS with transactions.

For HTTP Virtual Service:
In the application side seeing connection timeout errors.
 

Environment

 

Release : 10.6 and up

CA Service Virtualization

Cause

 

"lisa.vse.tcp.uses.nio" is the property that controls whether or not to use our non-blocking IO engine (NIO) when handling TCP traffic for virtual services. It will do this for both plain TCP (non-SSL/TLS) connections and SSL/TLS over TCP connections. The default for this property is true, which means we will use NIO for plain and SSL/TLS TCP connections. Sometimes using the default value causes the issue.

Resolution

Set the property  lisa.vse.tcp.uses.nio=false in VSE local.properties and restarting VSE should  resolve the issue.

Additional Information

Refer to section "DevTest CICS Agent Message Descriptions" in the documentation of the release of DevTest you are running.