Chrome version 91.0.4472.77 Edge Version Version 91.0.864.37 no longer work with cabi, data access error
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Chrome version 91.0.4472.77 Edge Version Version 91.0.864.37 no longer work with cabi, data access error

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Article ID: 216108

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) Unified Infrastructure Management for Mainframe CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

Symptoms of the issues reported:

1. Prior to update to the latest version of Chrome, was able to get into the UIM Home page or Dashboards -> IM Overview. Now seeing data access error after updating to these Chrome as well as Edge versions.

2. Also, you may find that when clicking on Reports in the Operator Console and running a report, you get sent to the CABI login screen no matter what report is run. The report does not load and you just get sent to a CABI login screen each time.

Environment

Release : 20.3

Component : UIM OPERATOR CONSOLE - WASP & CORE

Cause

This is specific to a samesite change in both browsers. It should only effect those users that are currently using http to connect to Operator Console and Cabi.

Resolution

The recommended resolution for this would be one of the following:

- Make the Operator Console and CABI (JasperServer) configured with HTTPS. Doc section: Configure CABI Server to Use HTTPS

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/20-3/installing/optional-post-installation-tasks/configure-https-in-admin-console-or-ump.html

- Use the "Lax" setting and access the Operator Console and CABI (JasperServer) using URL that has same subdomain and domain. 

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/20-3/installing/ca-business-intelligence-with-ca-uim/installing-and-upgrading-ca-business-intelligence-jasperreports-server-with-ca-uim/install-or-upgrade-for-a-bundled-ca-business-intelligence-jasperreports-server.html#concept.dita_c2a97a88c62cb3b239ae19b62fa62638ef4156bf_Troubleshooting

Alternatively the following can be set:

For Chrome add the following to the machine where Chrome is installed:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome

Add dword value:

type: dword
name: LegacySameSiteCookieBehaviorEnabled
value: 00000001

Add Key:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome\LegacySameSiteCookieBehaviorEnabledForDomainList

Add string value:

type: string
name: 1
value: *.<your-company-domain>.com
for example *.broadcom.com

For Edge:

Add dword value:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge

type: dword
name: LegacySameSiteCookieBehaviorEnabled
value: 00000001

 

After applying the registry changes for the respective browser, clear cache for all time and reopen the browser.

Additional Information

https://support.google.com/chrome/a/answer/7679408?hl=en#zippy=%2Cchrome