search cancel

OPEN JDK 11 has vulnerabilities, When CA Automic will start supporting higher version of OPEN JDK

book

Article ID: 216018

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

According to the document currently, OPEN JDK 11 is supported by CA Automic 12.3 version. As this OPEN JDK has vulnerabilities could you please advise by when CA Automic will release a new version that can support the higher version of OPEN JDK?

Meanwhile, could you also share how to handle the vulnerabilities with OPEN JDK 11. 

 

Environment

Release : 12.3

Component : AUTOMATION ENGINE

Resolution

These are the java versions that are supported with Automation Engine 12.3.5.

Open JDK Java 11 

Oracle Java 1.8 

Oracle Java 11 

 As long as you are on the same major version of open JDK 11.0 it is fine to upgrade to the latest build

The current version is 11.0.11+9

https://adoptopenjdk.net/

After upgrading to the latest build of the open JDK 11.0 release the scan results did not show any vulnerability