Encoded name or "[empty filename]" in Identified attachments list of Message Audit Logs
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Encoded name or "[empty filename]" in Identified attachments list of Message Audit Logs

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Article ID: 215963

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Updated On:

Products

Messaging Gateway

Issue/Introduction

When viewing the Message Audit Log (MAL) entry for a message in Messaging Gateway (SMG) the Identified attachments list contains one or more entries with "[empty filename]" or an encoded string.

Cause

This can occur for multiple reasons:

  • The filename portion of the attachment MIME boundary contains characters or information that could not be safely processed by the malware decomposer engine and so "[empty filename]" is used as a replacement value

  • The file name "[empty filename]" is technically a valid file name and that is the name in the attachment MIME boundary:
    ------=_Part_63541_28503634.1143813991285
    Content-Type: APPLICATION/OCTET-STREAM; name="[empty filename]"
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment; filename="[empty filename]"; size=18944

Resolution

Most issues with the malware decomposer engine processing some file names has been addressed in the currently available SMG versions and malware engines. Confirm that your SMG system version is updated and is receiving malware engine updates by:

SMG version:

  1. Click on Administration
  2. Click on Version in the left pane
  3. Click on the Updates tab.

Malware scanning engine version:

  1. Going to Status > Hosts
  2. Opening the Software and Services tab
  3. Confirm that all scanners have a recent virus definition version

Attachments