Registry.log SecretCallbackHandler cannot be found
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Registry.log SecretCallbackHandler cannot be found

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Article ID: 215885

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Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

 


After upgrading SOI to SO15850 / CU1 / Tomcat 7.0.107, a lot of the following entries are noted in the registry.log:
ERROR [Start Level Event Dispatcher] secret.SecretCallbackHandlerFactory.handleException(91)  - A SecretCallbackHandler cannot be found for class name : com.ca.catalyst.security.util.WS02SecretCallbackHandler
 
ERROR [Start Level Event Dispatcher] internal.Activator.startDeploy(70)  - Cannot start User Manager Core bundle
org.wso2.securevault.SecureVaultException: A SecretCallbackHandler cannot be found for class name : com.ca.catalyst.security.util.WS02SecretCallbackHandler
                ...
Caused by: java.lang.ClassNotFoundException: com.ca.catalyst.security.util.WS02SecretCallbackHandler
 

Environment

Release : 4.2

Component : SOI ALERT MANAGEMENT

Cause

 
 

Similar errors have been present at previous patch levels so this is not specific to just upgrading to CU1

There is no known impact to the errors.

Resolution

 
 

To remove errors from registry.log file, the following actions need to be performed:


1) Stop All SOI Services
2) Open folder CA\SOI\wso2registry\repository\components\lib on SOI manager machine
3) Copy Following 3 files into the above folder:
     CA\SOI\wso2registry\lib\catalyst.security.util-4.2.0.jar
     CA\SOI\wso2registry\lib\common.crypto-4.2.0.jar 
     CA\SOI\wso2registry\lib\jsafeJCEFIPS-5.0.jar 
4) Delete all logs from CA\SOI\tomcat\logs
5) Start SOI MQ Server Service and SOI Application Server Service first
6) Once SOI Manager triage tests are Completed, start other services one by one.

This process will be fixed in the next available patch release.