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API-1019 Error when trying to add choice to new picklist

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Article ID: 215879

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When trying to create a new choice in a picklist in the Modern User Experience (UX), intermittently get error: API-1019 : Could not process the request due to internal error.  This issue may be intermittent and may be noticed after creating your first choice (or a few choices after that).

Areas this has been reproduced include:

  • Custom Investments
  • Roadmaps

STEPS TO REPRODUCE

  1. In Modern User Experience (UX), go to Custom Investments
  2. Click on a Custom Investment
  3. Make a change to the view, such as add a column
  4. Click Save, to save the view
  5. Click on View Options
  6. Click Manage Picklists
  7. Click New Picklist and enter a name
  8. Add one choice

Expected Results: Add choice is able to be clicked to create a new choice

Actual Results: Add Choice is disabled and you get error API-1019 : Could not process the request due to internal error 

Note: This issue can also be reproduced without making a change to the view or columns. Sometimes when you click into the custom investment, then follow steps 5-9 above, the issue happens.

Error in app-ca.logs:

ERROR 2021-06-01 10:47:47,889 [http-nio-1577-exec-590] ppm.rest (clarity:admin:.....:PPM_REST_API) something happened while updating positioncom.niku.union.persistence.PersistenceDeadlockException: SQL error code: 1205Error message: [CA Clarity][SQLServer JDBC Driver][SQLServer]Transaction (Process ID 64) was deadlocked on lock resources with another process and has been chosen as the deadlock victim. Rerun the transaction.Executed

Cause

This is caused by DE61221

Environment

Release : 15.9.2

Component : CLARITY STUDIO

Resolution

This issue is fixed in 15.9.3 as DE61221

Workaround: Refresh the screen

Additional Information

See also: