Agent not able to download change set from TFS
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Agent not able to download change set from TFS

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Article ID: 215806

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Updated On:

Products

CA Release Automation - Release Operations Center (Nolio)

Issue/Introduction

We are using RA along with TFS where in RA the rum command line action will be fetching changes set from TFS using tfs power tools. 

We noticed that our deployment is getting successfully finished, but the changes set are not getting downloaded on agents.

Environment

Release : 6.x

Component : CA RELEASE AUTOMATION CORE

Cause

After troubleshooting the action execution information, the below cause is identified for problems being faced.

  • Why change set is not getting downloaded from TFS to agent?

The cause of issue is because of the below error on agent

Show Execution Information
Run Command Line action has finished successfully.
Return value: 100
Std out: Getting the changes in changeset 33794...
Std errTF30063You are not authorized to access http://iltfs/tfs/ILProjectCollection05.
Command line executed: tfpt getcs -changeset:33794 /force /overwrite "/login:ex-domain\demouser,*****"
Close
  • Why the process is not failing even there is an error?

As mentioned there is bad configuration in your action, which is not expecting any return code and hence for non-successful execution also the action/process is not failing.

Resolution

  • Why change set is not getting downloaded from TFS to agent?

The reason of failure is the user used in fetching the change set from TFS is denied the access with "Unauthorized Access". Please validate below recommendations

    1. Please validate if the password used in action for user is correct.
    2. It can also be an issue with TFS caches. TFS caches the credentials for TFS accounts and can result in the error. Try to clear the TFS cache and reconnect the TFS.
    3. It can be that this AD account password would have expired and hence not been able to successfully authorize. Please check with your LDAP/AD team to get a new password and retry.
    4. It is also possible that due to invalid password and frequent invalid login attempts have resulted in suspension or lock of this user account. Please validate the same with your AD team.
    5. On agent machine try to run the command manually to make sure it succeeds before trying the command within RA action
  • Why the process is not failing even there is an error?

We recommend to set and expect the correct Expected Return Value[Integer] in your action, so it can fail at right place and becomes easy to debug