Cannot discover Meraki MX67 device because only responded to ICMP
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Cannot discover Meraki MX67 device because only responded to ICMP

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Article ID: 215803

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Updated On:

Products

CA Performance Management - Usage and Administration

Issue/Introduction

Meraki MX67 devices are certified in Performance Management 20.2.10 with these Metric Family and Vendor Certification:

MF: System |  NormalizedSystemInfo
VC: Cisco Meraki System Statistics | CiscoMerakiManagementMib

However, when running a Discovery against these devices it fails with the message "Devices only responded to ICMP and were not created".

This would mean the device was not responding to the SNMP based discovery requests sent to it by the Data Collector.

Environment

Release : 20.2.10

Component : IM Reporting / Admin / Configuration

Cause

Some Meraki devices does not use sysUpTime, but instead sysORUptime OID. If sysORUptime is not present on the device or return 0 value, the discovery fails.

Resolution

Some Meraki devices does not respond to the OID sysUpTime, so in Performance Management an additional check is done for OID sysORUptime.

The "Cisco Meraki System Statistics" Vendor Certification uses sysORUptime (1.3.6.1.2.1.1.9.1.4) attribute on the device instead of sysUpTime.

These are the relevant OIDs for this Vendor Certification:

<Attribute name="sysDescr" external="true" type="OctetString">
                        <Documentation/>
                        <IsKey>true</IsKey>
                        <Source>1.3.6.1.2.1.1.1.0</Source>
                </Attribute>
                
               <Attribute external="true" name="sysObjectID" type="ObjectID">
                        <IsKey>true</IsKey>
                        <Source>1.3.6.1.2.1.1.2.0</Source>
                </Attribute>

                        <Attribute name="sysORUpTime" external="true" type="ObjectID">
                                <Source>1.3.6.1.2.1.1.9.1.4</Source>
                                <IsKey>true</IsKey>
                                <IsIndex>true</IsIndex>
                        </Attribute>


If the OID sysORUptime (1.3.6.1.2.1.1.9.1.4) is not returned (returns 0 value) from the devices, then they cannot be properly discovered.

In this case, need to investigate with the device vendor why sysORUptime is not returning any value.