Unable to login into WCC - Error message "E150010: Login failed. The EEM is down."
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Unable to login into WCC - Error message "E150010: Login failed. The EEM is down."

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Article ID: 215786

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Updated On:

Products

Autosys Workload Automation

Issue/Introduction

The Workload Control Center users are unable to log in. It returns the error - "E150010: Login failed. The EEM is down."

Whereas, the EEM Services are running fine.  Able to log in to the EEM portal with EiamAdmin credentials. 

The CA-wcc.log has the following message - 

INFO   | jvm 1    | 2021/05/24 10:22:33 |    23491 | @tomcat-resource < status-check-1> []  WARN #EEMStatusCheck                     # Cannot ping the EEM backend ...
INFO   | jvm 1    | 2021/05/24 10:22:46 |    23504 | @tomcat-resource < status-check-1> []  WARN #EEMStatusCheck                     # Cannot ping the EEM backend ...
INFO   | jvm 1    | 2021/05/24 10:22:56 |    23514 | @tomcat-resource < status-check-1> [] ERROR #EmbIAMAccessProvider               # EmbIAMAccessProvider - SafeContextFactory.getSafeContext failed for config: AccessConfig[HostName=eemserver.broadcom.com, Locale=en_US, ServerEnabled=true, AppName=WCC0004, AppCertPath=/opt/CA/WorkloadCC/data/config/wcc.pem, ServerAdminID=EiamAdmin, EventLogPath=null, PersistentCachePath=null, RetryConnectInterval=30, RetryPingInterval=30, FullCacheUpdateEnabled=false, CacheUpdateInterval=30], SafeException.getMessage = EE_BADOBJECT Bad Object
INFO   | jvm 1    | 2021/05/24 10:22:56 |    23514 | [Path (/opt/CA/WorkloadCC/log/eem/audit) doesn't exists]
INFO   | jvm 1    | 2021/05/24 10:22:56 |    23514 | com.ca.eiam.SafeException: EE_BADOBJECT Bad Object
INFO   | jvm 1    | 2021/05/24 10:22:56 |    23514 |    at com.ca.eiam.SafeContext.setSafLocation(SafeContext.java:9681)
INFO   | jvm 1    | 2021/05/24 10:22:56 |    23514 |    at com.ca.eiam.SafeContext.attach(SafeContext.java:1365)

Environment

Release: 11.3.6 and higher

Component : WORKLOAD CONTROL CENTER

Cause

The message is due to either missing or permissions issue for the WCC service owner(wcc) on the directory "/opt/CA/WorkloadCC/log/eem/audit"

Resolution

The default permissions for the WCC install directories should not be changed. They are the minimum permissions required for WCC functionality.

Below are the default permissions for the files and directories under  $CA_WCC_INSTALL_LOCATION/log.

 # ls -lrt

total 120692

drwxr-x---.  3 wcc wcc       44 Sep  5  2019 eem

drwxr-x---. 18 wcc wcc      279 Sep  5  2019 application

drwxr-xr-x.  2 wcc wcc       23 Sep  5  2019 audit

drwxr-x---.  3 wcc wcc      216 Sep  5  2019 install

-rw-r--r--.  1 wcc wcc 10239997 May 24 20:58 CA-wcc.log

-rw-r--r--.  1 wcc wcc 10239998 May 24 21:07 CA-wcc-services.log

 # cd eem

 # ls -lrt

total 0

-rwxr-x---. 1 wcc wcc   0 Apr 24  2017 eiam.sdk.java.log

drwxr-x---. 2 wcc wcc 281 Oct 15  2019 audit

 

The problem will be resolved after ensuring the required permissions for the directories eem, application, install, audit under $CA_WCC_INSTALL_LOG/log