search cancel

UIM Upgrade from 9.0.2 to 20.3.0 fails at 30% "An error occurred during installation"

book

Article ID: 215761

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) Unified Infrastructure Management for Mainframe CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

UIM Upgrade fails at 30% "An error occurred during installation"

The installation logs show the below

2021-05-18 10:57:02,704 INFO  impl.UIMServerConfigureController:waitForProbeToRespondCommon:3297 [Thread-42]  - trying to connect on loopback address as secure bus is enabled.
2021-05-18 10:57:02,705 DEBUG pds.PDSController:send:177 [Thread-42]  - Sending 'nametoip' with sid: null, timeout: 30000
2021-05-18 10:57:03,699 WARN  probe.ProbeController:waitForResponse:245 [Thread-42]  - nametoip failed: (80) Session error, Unable to open a client session for 127.0.0.1:48000: Connection refused: connect

2021-05-18 11:02:03,939 ERROR probe.ProbeController:waitForResponse:256 [Thread-42]  - Failed to communicate with probe 'controller' in the allotted time.
2021-05-18 11:02:03,942 ERROR impl.UIMServerConfigureController:run:478 [Thread-42]  - NimException caught
(6) permission denied, Failed to communicate with probe 'controller' in the allotted time of 300 secs.

The controller log which is not allowing to start UIM

May 18 12:46:43:493 [13176] 0 Controller: No proxy certificate authority found to permit encrypted communcation between hubs and robots, cannot continue
May 18 12:46:43:493 [13176] 0 Controller: Proxy ssl initialialization failed. Exiting...

During the upgrade wizard unable to uncheck the "enable secure bus binaries"

Environment

UIM 9.0.2

HUB 9.x

Cause

The issue was identified as the hub_secure v9.33 was installed on the primary hub while the environment doesn't have secure probes.

Resolution

- Deploy the hub v.9.33 to overwrite the hub_secure v9.33 which will cause the primary hub to restart.
- Run the UIM upgrade 20.3.0 setupCAUIMServer.

Attachments