search cancel

UIM CABI -report timeout and applicationcontext.xml

book

Article ID: 215710

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We have issues with reports failing after 60 minutes

UIM 20.3

cabi 4.30

wasp 20.32

robot 9.32

 

Environment

Release : 20.3

Component : UIM - CABI

Cause

From jasperserver.log:
com.jaspersoft.jasperserver.api.JSException: jsexception.jasperprint.not.found".

That means the more number of reports are being executed in parallel and it is exceeding the maximum number of objects that jasper server creates to access reports.

Resolution

The maximum number of objects that jasper server creates to access reports can be configured in "../wasp/webapps/cabijs/WEB-INF/applicationContext.xml"

Please set the maxSize to a higher number and restart the cabi server. Once the server is up and running, please retest the issue. Provide us the latest jasperserver.log file if the issue still persists.

Attachments