Spectrum OneClick is unable to connect to the SpectroSERVER
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Spectrum OneClick is unable to connect to the SpectroSERVER

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Article ID: 215669

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Updated On:

Products

CA Spectrum

Issue/Introduction

After installing a Spectrum patch, OneClick is unable to connect to one of the SpectroSERVER systems. Specifically the MLS system.

The OneClick Landscapes page is showing the following error:

 

The VNM.OUT file on the SpectroSERVER system is showing the following error:

May 21 18:18:24 ERROR TRACE at CsCorbaMgr.cc(1279): Failed to connect to CORBA Naming Service on corbaloc::spectrum:14006/NameService, will retry in 5 seconds.

May 21 18:18:25 : SpectroSERVER has received shut down signal - scheduling shut down
May 21 18:18:25 : /opt/CA/Spectrum/SS/SpectroSERVER is shutting down...
May 21 18:18:25 : Closing all client connections...
May 21 18:18:25 : Bypassing CORBA shutdown...
May 21 18:19:14 ERROR TRACE at CsCorbaMgr.cc(1279): Failed to connect to CORBA Naming Service on corbaloc::spectrum:14006/NameService, will retry in 5 seconds.
May 21 18:20:04 ERROR TRACE at CsCorbaMgr.cc(1279): Failed to connect to CORBA Naming Service on corbaloc::spectrum:14006/NameService, will retry in 5 seconds.
May 21 18:20:54 ERROR TRACE at CsCorbaMgr.cc(1279): Failed to connect to CORBA Naming Service on corbaloc::spectrum:14006/NameService, will retry in 5 seconds.
May 21 18:21:44 ERROR TRACE at CsCorbaMgr.cc(1279): Failed to connect to CORBA Naming Service on corbaloc::spectrum:14006/NameService, will retry in 5 seconds.

Environment

Release : Any

Component : Spectrum Core / SpectroSERVER

Cause

A check on the SpectroSERVER system shows not all of the Spectrum processes are running. Specifically the NameService.

Resolution

Gracefully shutdown all of the Spectrum processes including processd.

Check the $SPECROOT/lib/SDPM/runtime directory for any files that end with .rtt and remove them.

Start processd as normal. Ensure the Spectrum processes start. Location service, Name service, telnetd etc.

Start the SpectroSERVER as normal.

If the issue persists, please contact Spectrum Support for assistance.