Applications Manager fails to start due to error message "signer information does not match signer info"
search cancel

Applications Manager fails to start due to error message "signer information does not match signer info"

book

Article ID: 215485

calendar_today

Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

After installing Applications Manager master/local agent or remote agent, or after installing or upgrading Java used by the master or agent, Applications Manager fails to start due to the below error.

Exception in thread "main" java.lang.SecurityException: class "com.appworx.util.DBG"'s signer information does not match signer information of other classes in the same package

 

Environment

Release : 9.2

Component : APPLICATIONS MANAGER

Cause

During start up, Java reads the jar files located in the $AW_HOME/web/classes directory and detects that the install.jar signer info does not match AppWorx.jar's signer info, even though the signer information has be confirmed the same.

The issue is a known defect.

Resolution

Known defect fixed in 9.4.0

Workaround:

1. Create a new directory under the $AW_HOME/web/classes directory and name it backup_jar or any name of your choosing.

2. Move the install.jar into the new directory.

3. Restart Applications Manager.