Faults not showing in Spectrum up for VNA APIC
search cancel

Faults not showing in Spectrum up for VNA APIC

book

Article ID: 215398

calendar_today

Updated On:

Products

CA Virtual Network Assurance

Issue/Introduction

I recently added a new APIC to an existing VNA Collector and ran a full sync in Spectrum. The inventory got synced but not the faults/alarms.

There are two more APICs on the same collector running 3.2 version and they are showing up fine but this new APIC is running 4.2 (5n) version and is not showing faults.

I ran a DB query like below and not finding any faults in the DB.

select * from notifications where userDomainId='xxx'; shows a full list of faults for the working domain ID but nothing for the userdomainID for the new APIC.

Environment

Release : 20.2

Component : Virtual Network Assurance For CA Spectrum

Cause

The Fault_Subscription_enabled field in the configuration was set to false.

Resolution

I reconfigured for the Fault_Subscription_enabled field in the config to "true" and recycled wildfly.

I can now see the faults coming in.