Not able to edit OC Account users password
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Not able to edit OC Account users password

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Article ID: 215294

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) Unified Infrastructure Management for Mainframe CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

We are using UIM 20.3. In the Operator console, and I am unable to edit passwords for Account Contact Users. My user is a NimBUS administrative user created via the Infrastructure Manager (IM) console.

Environment

Release : 20.3

Component : UIM OPERATOR CONSOLE - ACCOUNT ADMIN

UIM 20.3.3

Cause

- small ease of use issue

Resolution

Note that if you create an administrator user using IM, you should still adhere to the password format that is enforced within the Operator Console:

As of UIM 20.3.3, an Account Contact can change their own password. Please refer to:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/20-3/administering/Change-Your-Password.html

Account Contact users can change their own password once they are logged in via the three dots/ellipsis by selecting "Change Password." Make sure your administrative user ACL has the permission checked for Change Password.

 

NimBUS administrative users created in IM that have the administrator ACL associated with their user id can change other's Account Contact passwords.

Note also that you cannot use the delete button as it will do nothing, the password must be 'typed over'/overwritten.

If you still have trouble, create a new NimBUS administrator user but adhere to the new password format. Login at least once to the IM with that new user and check to make sure that the proper ACL is applied to the user upon login.

Then login to OC as that new administrator and try to change a user's password.

Additional Information

Listed below are the steps on how to change a new (or existing) NimBUS administrator user's password:
 
  1. In the Infrastructure Manager (IM), create a new NimBUS user.
  2. Associate ACL, in this case the Administrator ACL.
  3. Enter the password and save the user by closing the "User Administration" window.
  4. Login to Admin Console with this user now and it should be successful.
  5. Login to IM as the new user and its successful and displays the correct-current user and ACL.
  6. Login to the Admin Console and select "Manage Users" and select the new user.
  7. Click in the password field and change the password.
  8. Click Update to update the password. (You should see "Updated user successfully")
  9. Logout of AC
  10. Login to AC again using the new password and it should be successful.

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